How to Publish/Unpublish Records

Frequently asked questions, including solutions to common problems, common tasks, and tips for using eHive.
paul
Posts: 193
Joined: Thu May 08, 2008 10:31 am
Location: Auckland

How to Publish/Unpublish Records

Postby paul » Wed Jun 10, 2009 3:38 pm

Publishing is currently part of the create/edit screens. When you save a new record from the create screens or edit and save an existing record, the message prompting you for the record's publishing settings will come up:

Publish Options
Would you also like to publish this record?

You'll be presented with an option to "Publish to eHive". Ticking this option will make the public fields of this record viewable by the public on the main eHive.com site.

If you belong to some communities, then you'll also get an option to publish this record to each of those communities.

These options will have defaults set up for your account. You can alter set the defaults for publishing to eHive through:
Home page -> Edit My Profile -> Preferences -> Allow Public Access?

You can alter the default publishing option for each community you belong to through:
Home page -> Communities -> Your Membership Details -> Edit -> Include as a default publishing location?

In the longer term we're planning to separate the publish/unpublish options from the record create/edit screen. These options would instead be available directly through the Toolbox at the right of the detail page for any record when you're logged in. This should make it clearer where the current record is published to, and give you a shorter route to changing this.

guildarchivist
Posts: 7
Joined: Sat Aug 01, 2009 6:47 am

Re: How to Publish/Unpublish Records

Postby guildarchivist » Sat Aug 01, 2009 6:52 am

Hi Paul,

I have created a record and saved it both as draft and also as a file (without publishing it eHive). I have edited it and added some more information and am ready to publish however although it saves as draft ok, everytime I go to publis,h whether it be to eHive or just within my account, it comes up with teh following error; "publishing failed dude to servor error" Any idea what I can do about this?

Thanks,

Michael.
Archivist
The British PUppet & Model Theatre Guild

paul
Posts: 193
Joined: Thu May 08, 2008 10:31 am
Location: Auckland

Re: How to Publish/Unpublish Records

Postby paul » Mon Aug 03, 2009 9:57 am

Hi Michael,
We haven't had this reported since the last eHive update (early July), so it's probably a specific case. What web browser and browser version are you using? e.g. Internet Explorer 8. The browser version is usually available through the Help menu - About ....

You could try a couple of things to see if it gets around the problem:
- When you edit the record, trying swapping to a different tab (such as Core or Public) before you save. This forces eHive to auto-save a draft first and may make a difference to the save.
- Try deleting any old draft for the record first from the Home page menu - View Drafts. Then edit the record and save it.

We'll also investigate it here and see if we can replicate the problem. If it ends up being browser specific, a temporary work-around while we develop a fix would be to install the latest version of another browser (e.g. Firefox 3.5, Chrome, Internet Explorer 8).

Regards,
Paul

guildarchivist
Posts: 7
Joined: Sat Aug 01, 2009 6:47 am

Re: How to Publish/Unpublish Records

Postby guildarchivist » Mon Aug 03, 2009 11:30 am

Hi Paul,

I'm using Explorer 7. Thanks for the tips, will try those out tomorrow. It's not a huge problem if I have to delete it and start again, but I have been preparing quite a few photos tonight in readiness to put a few records on and if it was something I was doing wrong I wanted to make sure before I started properly.

I will try what you suggested and let you know.

Michael.

guildarchivist
Posts: 7
Joined: Sat Aug 01, 2009 6:47 am

Re: How to Publish/Unpublish Records

Postby guildarchivist » Tue Aug 04, 2009 11:14 am

Just to update you - all working fine now! Original has uploaded and is now viewable on eHive (public).

Have to say I have only added one item from the collection so far, but I am getting more and more impressed with eHive and looking forward to using it. Well done to you all.

Michael.
The National Puppetry Archive

paul
Posts: 193
Joined: Thu May 08, 2008 10:31 am
Location: Auckland

Re: How to Publish/Unpublish Records

Postby paul » Tue Aug 04, 2009 11:40 am

Good to hear. One possibility is a time out or internet connection problem. e.g. Temporary loss of internet connection during the save process.

The update to the site at the end of the month has a lot of new features.
http://ehive.com/index.php?option=com_ehiveblog&task=showBlogArticle&blogId=50&Itemid=136

Regards,
Paul

JAC
Posts: 1
Joined: Fri Sep 18, 2009 5:30 am

Re: How to Publish/Unpublish Records

Postby JAC » Wed Sep 23, 2009 1:27 am

Hi Paul,

I'm having a similar problem to this thread - cannot Publish to public view.

Have sent 2 requests for assistance to the info mail-box - nada ....

we are registered as the CHS - Charlestown Historical Society

entered 3 test records, and can see them on the home page, but cannot make them Public.

Help !

rgrds

Allan C
ajcrawford01@hotmail.com

paul
Posts: 193
Joined: Thu May 08, 2008 10:31 am
Location: Auckland

Re: How to Publish/Unpublish Records

Postby paul » Fri Sep 25, 2009 12:27 pm

Hi Allan,
It sounds like it might be a bug introduced in the Sep 15th upgrade. Do you seem to get any error which you tick the 'Publish to eHive' option on saving? What web browser (and version) are you using? You can usually see this through Help - About ....

Cheers,
Paul

paul
Posts: 193
Joined: Thu May 08, 2008 10:31 am
Location: Auckland

Re: How to Publish/Unpublish Records

Postby paul » Fri Sep 25, 2009 6:32 pm

We've found and fixed one bug with the publishing of records today, so give it another try.
Paul

guildarchivist
Posts: 7
Joined: Sat Aug 01, 2009 6:47 am

Re: How to Publish/Unpublish Records

Postby guildarchivist » Sun Nov 08, 2009 10:45 am

Hi Paul,

I'm having the same problem again, when I go to publish to ehive option it comes up with; "Publishing Failed due to sever error". I have tried saving as draft first but still no luck.

I have recently upgraded to Internet Explorer 8.

Any ideas? It was working just fine before, but I haven't added anything for a while and want to add quite a bit this weekend if possible.

Thanks!

Michael.


Return to “Frequently Asked Questions”

Who is online

Users browsing this forum: No registered users and 2 guests