Search Results Pagination

Ask questions related to the eHive application programming interfaces, including the OAI-PMH data harvester, REST API and WordPress plugins.
ChrisPixel
Posts: 3
Joined: Thu Feb 05, 2015 3:43 am

Search Results Pagination

Postby ChrisPixel » Fri Feb 06, 2015 1:03 am

Hi eHive,

We have been setting up an integration of eHive into a WordPress site using the eHive plugins. There is strange bug which we can’t get to the bottom of and hope you can help.

When doing a search the results are paginated, say 10 pages. When we click on next or 2 etc the results change, but after the first page change all of the pagination links update to link to the current page you are looking at so the user cannot navigate through the results.

Thinking there might be a conflict with the theme or other plugins we have setup a fresh install of WordPress with the default theme and just eHive but the problem persists.

Here is the demo site: http://ehive.pixelparlourdesign.com/

You can start an eHive Search here: http://ehive.pixelparlourdesign.com/search

Example eHive search results: http://ehive.pixelparlourdesign.com/sea ... ry=folding

After the first page change it just ceases up. Any thoughts on what might be causing this would be appreciated.

Thanks,
Chris

Naomi
Posts: 29
Joined: Tue Oct 14, 2014 2:18 pm

Re: Search Results Pagination

Postby Naomi » Fri Feb 13, 2015 10:27 am

Hi Chris,

Our development team will look into this and get back to you soon.

Many thanks,
Naomi

Darren
Posts: 20
Joined: Fri Dec 07, 2012 8:23 am

Re: Search Results Pagination

Postby Darren » Fri Feb 13, 2015 10:51 am

Hi Chris

Have taken a look at the pagination problem on your demo site and can see the issue.

Tested other current production sites and cannot reproduce the problem.

Looks like the eHive search plugin is conflicting with the latest WordPress.

I am away from the office next week, will schedule investigation of this for the following week.

Kind regards
Darren

ChrisPixel
Posts: 3
Joined: Thu Feb 05, 2015 3:43 am

Re: Search Results Pagination

Postby ChrisPixel » Thu Feb 19, 2015 1:53 am

Hi Darren,

Thanks for your update. Let me know how you get on. Something else I have spotted with the search is that if you have the site in a subdirectory like www.websiteaddress.com/mysite - ehive records that don't have an image the fallback no photo image doesn't load. Looks like the path to the file is in the plugin as /wp-content/plugins/ehive-search/images/search_item_list.png

Might need path adjusted to be relative to the site url.

Thanks,
Chris

Darren
Posts: 20
Joined: Fri Dec 07, 2012 8:23 am

Re: Search Results Pagination

Postby Darren » Mon Feb 23, 2015 10:11 am

Hi Chris

Have done a fresh install of the eHive plugins with the latest Wordpress 4.1.1 using the Twenty Fifteen theme. I cannot reproduce the pagination problem.

What version of Wordpress are you using, and what theme are you using? How is the permalink configured?

Is it possible to send me a copy of the theme for testing.

Thank you for the details on the fallback image problem.

Regards
Darren

Darren
Posts: 20
Joined: Fri Dec 07, 2012 8:23 am

Re: Search Results Pagination

Postby Darren » Tue Feb 24, 2015 6:32 am

Hi Chris

Have uploaded to the WordPress plugins repository a fix for the fallback no image not loading when WordPress is installed in a sub folder.

eHive Search version 2.1.5

Thank you for your input on this.

Regards
Darren

ChrisPixel
Posts: 3
Joined: Thu Feb 05, 2015 3:43 am

Re: Search Results Pagination

Postby ChrisPixel » Fri Feb 27, 2015 3:57 am

Hi Darren,

Thanks for looking into this and trying to replicate the pagination issue. I think the problem was to do with the WordPress 4.1 release which was breaking the search pagination. Our development and live sites have updated to WordPress 4.1.1 and with nothing else changed the search is fully working on all of them!

Also thanks for adjusting the fallback image link. Happy to have helped find this.

For your interest here is what our integration of eHive looks like - http://www.thefanmuseum.org.uk/collections/

All the best,
Chris


Return to “Developers”

Who is online

Users browsing this forum: No registered users and 1 guest