Error in search

Ask questions related to the eHive application programming interfaces, including the OAI-PMH data harvester, REST API and WordPress plugins.
randy.dersham
Posts: 6
Joined: Mon Dec 03, 2012 3:31 pm

Error in search

Postby randy.dersham » Wed Dec 05, 2012 4:54 pm

Fatal error: Call to undefined method EHiveApi::getObjectRecords() in /nfs/c08/h02/mnt/120500/domains/mckenzieriverdriftboatmuseum.org/html/wp-content/plugins/eHiveSearch/EHiveSearch.php on line 384

I've just set up and have all working except the search. I'm guessing that I'm missing a paramater. Can you tell me what this line 384 error of the search .php is and how to fix it.

Andy Scott
Posts: 7
Joined: Mon Dec 03, 2012 12:42 pm

Re: Error in search

Postby Andy Scott » Thu Dec 06, 2012 7:06 am

Hi Randy,

This one was a bug... I have uploaded the fix this morning (version 2.0.2-beta).

Hope this helps,

Andy

randy.dersham
Posts: 6
Joined: Mon Dec 03, 2012 3:31 pm

Re: Error in search

Postby randy.dersham » Thu Dec 06, 2012 8:48 am

Thank you. I've now downloaded and replaced the plugin. The search does not return any results. I've tried with the search on the top of my object grid and with the search on it's own page. In both the action is the same. I type in a search word, click search, the search appears to be working-at least it reloads the page, but no search results are returned. It appears as if the page has simply been reloaded.

Any ideas?

Darren
Posts: 20
Joined: Fri Dec 07, 2012 8:23 am

Re: Error in search

Postby Darren » Fri Dec 07, 2012 10:39 am

Hi Randy

In the eHive Search Settings in the Results view section can you check that at least one result view is selected and set as the default view.

Darren

randy.dersham
Posts: 6
Joined: Mon Dec 03, 2012 3:31 pm

Re: Error in search

Postby randy.dersham » Sat Dec 08, 2012 10:03 am

Yes, In SearchSettings/result view I have checked both list and lightbox with the radio button selecting list.

Darren
Posts: 20
Joined: Fri Dec 07, 2012 8:23 am

Re: Error in search

Postby Darren » Sat Dec 08, 2012 12:53 pm

Hi Randy

I looked up your account profile page in eHive, http://ehive.com/account/4461 McKenzie River Drift Boat Museum. It does not show any object records. I am assuming that all of your objects are private.

The API only displays objects that are public.

Could you edit one of your objects in eHive and save it as public / published to eHive, then search for it from the plugin.

Darren

randy.dersham
Posts: 6
Joined: Mon Dec 03, 2012 3:31 pm

Re: Error in search

Postby randy.dersham » Mon Dec 10, 2012 5:32 pm

http://mckenzieriverdriftboatmuseum.org/photo-collection/

Above is a link to the page on my site that has a search above an object grid that has been pulled from public ehive objects. The grid is being pulled from ehive and if you click on an image it will show the correct Object Page for that object. I'm trying to search for public ehive objects to insure that my website code is working before I try to set up a object grid and search for only my images.

I have one object in my collection. It was private, I have now made it public and published to ehive. Thank you for the help.

Darren
Posts: 20
Joined: Fri Dec 07, 2012 8:23 am

Re: Error in search

Postby Darren » Mon Dec 10, 2012 7:46 pm

In the eHiveAccess settings page the search page setting will need to be set to your photo-collection page for the search to work.

randy.dersham
Posts: 6
Joined: Mon Dec 03, 2012 3:31 pm

Re: Error in search

Postby randy.dersham » Tue Dec 11, 2012 12:37 pm

Yes sir, in ehive/settings under Search Page it is set to the page photo collection. There is no hyphen. Does that matter?

randy.dersham
Posts: 6
Joined: Mon Dec 03, 2012 3:31 pm

Re: Error in search

Postby randy.dersham » Tue Dec 11, 2012 12:40 pm

I have switched the page to show only my site images. That worked fine. Now there is the one image showing from my collection on the Photo Collection page and it will bring up the Object Page if I click on the square image. Very nice. The search still seems to only refresh the screen.


Return to “Developers”

Who is online

Users browsing this forum: No registered users and 1 guest